最小生成树

最小生成树的Kruskal算法原理

  • 初始阶段所有节点都是孤立的集合
  • 按照的权重进行排序,再进行遍历,如果某条边的两个顶点分属不同的集合,则该边为最小生成树的一条边,并将这两个顶点分属的集合合并。
  • 遍历完所有的边后,原图上所有的节点属于同一集合;否则原图不连通,最小生成树不存在。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
struct edge
{
int a,b;
int cost;
bool operator < (const edge &A) const
{
return cost<A.cost;
}
}

int result(edge e,int n)
{

int* tree=new int(n);
for(int i=0;i<n;i++)
{
tree[i]=-1;
}
sort(edge,edge+n);
int ans=0;
for(int i=0;i<n;i++)
{
int aRoot=findRoot(edge[i].a);
int bRoot=findRoot(edge[i].b);
if(a!=b)
{
tree[a]=b;
ans+=edge[i].cost;
}
}
return ans;
}

例子:畅通工程

描述

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

output

对每个测试用例,在1行里输出最小的公路总长度。

sample input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

sample output

3
5

杭电1233题

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#include<stdio.h>
#include<algorithm>
using namespace std;
struct edge
{
int a,b;
int cost;
bool operator < (const edge &A) const
{
return cost<A.cost;
}
}e[5000];
int tree[105];
int findRoot(int x)
{

if(tree[x]==-1) return x;
else
{
int temp=findRoot(tree[x]);
tree[x]=temp;
return temp;
}
}
int main()
{

int N;
while(scanf("%d",&N)!=EOF)
{
int m=N*(N-1)/2;
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&e[i].a,&e[i].b,&e[i].cost);
}
for(int i=1;i<=N;i++)
tree[i]=-1;
sort(e+1,e+m+1);
int sum=0;
for(int i=1;i<=m;i++)
{
int aRoot=findRoot(e[i].a);
int bRoot=findRoot(e[i].b);
if(aRoot!=bRoot)
{
tree[aRoot]=bRoot;
sum+=e[i].cost;
}
}
printf("%d\n",sum);
}
return 0;
}