map

九度1450题 产生冠军

描述

有一群人,打乒乓球比赛,两两捉对撕杀,每两个人之间最多打一场比赛。
球赛的规则如下:
如果A打败了B,B又打败了C,而A与C之间没有进行过比赛,那么就认定,A一定能打败C。
如果A打败了B,B又打败了C,而且,C又打败了A,那么A、B、C三者都不可能成为冠军。
根据这个规则,无需循环较量,或许就能确定冠军。你的任务就是面对一群比赛选手,在经过了若干场撕杀之后,确定是否已经实际上产生了冠军。

输入

输入含有一些选手群,每群选手都以一个整数n(n<1000)开头,后跟n对选手的比赛结果,比赛结果以一对选手名字(中间隔一空格)表示,前者战胜后者。如果n为0,则表示输入结束。

输出

对于每个选手群,若你判断出产生了冠军,则在一行中输出“Yes”,否则在一行中输出“No”。

样例输入

3
Alice Bob
Smith John
Alice Smith
5
a c
c d
d e
b e
a d
0

样例输出

Yes
No

这是拓扑排序问题,如果全图中只有一个入度为0的节点,那么就能产生冠军

定义一个In数组来记录所有选手的入度(被打败的次数),因为输入的字符串,所以需要map数组来转换成int型,作为in数组的下标。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
#include <iostream>
#include<stdio.h>
#include<map>
#include<string>
#include<string.h>
using namespace std;
map<string,int> M;

int main()
{

int n;
int in[2005];
char str1[20];
char str2[20];
while(scanf("%d",&n)!=EOF&&n!=0)
{
M.clear();
for(int i=0;i<2*n;i++) //n组胜负关系,之多存在2n个队伍
{
in[i]=0;
}
int index=0;
for(int i=0;i<n;i++)
{
scanf("%s%s",str1,str2);
if(M.find(str1)==M.end())//如果map中不存在,则加入
{
M[str1]=index;
index++;
}
int indexB;
if(M.find(str2)==M.end())//如果map中不存在,则加入,并记录下标,in[下标]++
{
indexB=index;
M[str2]=index;
index++;
}
else
{
indexB=M[str2];
}
in[indexB]++;
}
int cnt=0;
for(int i=0;i<index;i++)
{
if(in[i]==0)
{
cnt++;
}
}
if(cnt==1)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}

map查找

1
2
3
map<string,int>::iterator its;
its=M.find(p);
cout<<(*its).second<<endl;